El blog de franz

Geek

Error 1935 en la instalación de ArcGIS

En algunos casos cuando se intenta instalar ArcGIS, suele aparecer el Error 1935 que impide culminar satisfactoriamente el proceso de instalación.

Error 1935 ArcGIS

Este error es generado por un problema de .NET Framework, por lo general muestra el siguiente mensaje:

Error 1935. An error occurred during the installation of assembly. ‘Microsoft.MSXML2R,  processorArchitecture = “x86″, publicKeyToken = “6bd6b9abf345378f”, version = “4.1.0.0”, type = “win32″. Please refer to Help and Support for more information.

También se puede constatar que aparece en blanco el cuadro de Activar o desactivar las características de Windows.

Activar o desactivar las características de Windows

Generalmente he tenido que instalar nuevamente el sistema operativo, pero el procedimiento que me ha funcionado para solucionar este problema se detalla a continuación:

 

  • Verificar cada versión de .NET Framework con su respectivo verificador.
  • Abrir la consola de comandos o símbolo de sistema como administrador (escribir en el menú inicio cmd).
  • Digitar sfc /scannow y pulsar enter (si muestra Low Registry Space existe un problema en la memoria, entonces continuar).
  • Abrir el editor de registro Regedit (con Inicio + R escribir regedit y aceptar).
  • Navegar hasta HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control.
  • Cambiar el valor DWORD de RegistrySizeLimit actualizando su información del valor por ffffffff en Hexadecimal, ahora marcar el valor Decimal y actualizar a 4294967295.
  • Reiniciar el ordenador e intentar instalar nuevamente.

Regedit RegistrySizeLimit

Con estos pasos he conseguido corregir este error sin tener que instalar nuevamente Windows, si no funciona pueden existir otros problemas en el sistema operativo, para mayor información visitar la ayuda de Esri sobre el error 1935.

 

Tagged , , , , , ,

9 thoughts on “Error 1935 en la instalación de ArcGIS

  1. Joel Marcano

    Amigo que versión de .NET Framework debo tener en mi equipo para poder instalar el arcgis, y el tema de este post se basa en la instalación del ArcGIS 10.0 ó 10.1?

    Reply
    • franzpc Post author

      Requieres Microsoft .NET Framework 3.5 SP1 (es gratis desde la web de Microsoft), este post esta hecho con la versión 10, pero es aplicables para las versiones 9.x y 10.x.

      Reply
      • Fredman

        Hola Franz, me explicas que debo de hacer para corregir este problema en la instalación. Sucede que me da este error que tu mencionas.

        Saludos.

        Reply
  2. Thed Northon Mena

    Hola tu blog esta magnifico es de gran ayuda. Una consulta donde encuentro algunas extensiones adicionales para el arcgis, ya que cuando instalo el arcgis 10.0 algunos comandos no funcionan y faltan extensiones.

    Reply
  3. roksaja

    Primero que nada quiero felicitarte por tu excelente blog. Después, quiero preguntarte sobre el error 1935 a mi me sale al momento de querer instalar el Erdas. La solución que aquí presentas funcionará en Erdas.

    Reply

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>